> 1 <

Автор Сообщение

Raino

Members


Статус

18 сообщений

Где: ---
Род занятий:
Возраст:

#2013   2010-05-10 04:22 GMT+3 часа(ов)      
Использую slime + emacs.
В REPL-е у меня есть автодополнение по TAB, но при редактировании самого .lisp файла оно не работает.

Настройки emacs:

(eval-after-load "slime"
`(progn
(slime-setup '(slime-repl))
(custom-set-variables
'(inhibit-splash-screen t)
'(slime-complete-symbol*-fancy t)
'(slime-complete-symbol-function 'slime-fuzzy-complete-symbol)
'(slime-net-coding-system 'utf-8-unix)
'(slime-startup-animation nil)
'(slime-lisp-implementations '((sbcl ("/usr/bin/sbcl")))))))

Как можно его включить?

Fallen_s4e

Members


Статус

114 сообщений
http://lisper.ru
Где: Zimbabwe lisper.ru
Род занятий: fallen_s4e
Возраст: 7

#2015   2010-05-10 12:25 GMT+3 часа(ов)      
Понятно что не работает - это же отступ.
У меня стоит на shift+tab:
(global-set-key (kbd "<backtab>") 'slime-indent-and-complete-symbol) ;"S-tab"
Посмотрите функции C-h k и C-h f.

Raino

Members


Статус

18 сообщений

Где: ---
Род занятий:
Возраст:

#2016   2010-05-10 17:55 GMT+3 часа(ов)      
В который раз выручаешь
А у меня в редакторе tab просто выравнивает строки, а обычную вставку символа табуляции и не делает, т.е. полностью аналогично repl.
Ну теперь уже все в порядке. Спасибо!

Fallen_s4e

Members


Статус

114 сообщений
http://lisper.ru
Где: Zimbabwe lisper.ru
Род занятий: fallen_s4e
Возраст: 7

#2020   2010-05-10 21:17 GMT+3 часа(ов)      
Рад помочь.=)
> 1 <


Онлайн :

0 пользователь(ей), 22 гость(ей) :




Реклама на сайте: